• Login:

Welcome to the Toshiba Thrive Forum.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

Results 1 to 4 of 4
  1. #1
    Thrive Lurker
    Member #
    27569
    Join Date
    Aug 2015
    Posts
    4
    Liked
    0 times

    can anyone help?

    im having a problem with my thrive...its not turning on anymore but when i plug it into my computer the usb recognizes it as APX....it automatically goes into apx mode without having to push the small button near the battery...im just wondering what could the problem be..its a 10" toshiba thrive from australia.

    (and yes it was rooted and used it for almost 2 years without breaking then one day it slowed down then i turned it off..then when i charged it the led is on but it wont turn on at all, i can't even go to recovery) any information/help is appreciated..thnx in advance

  2. Ads


  3. #2
    Thrive Lurker
    Member #
    27569
    Join Date
    Aug 2015
    Posts
    4
    Liked
    0 times
    bump

  4. #3
    Thrive Pursuant
    Member #
    11298
    Join Date
    Feb 2012
    Location
    Where No Man Has Gone Before: The Planet Phi-Epsilon Nudist Colony For Women
    Posts
    503
    Liked
    67 times
    Have you tried removing and reseating the battery?

  5. #4
    Thrive Lurker
    Member #
    27569
    Join Date
    Aug 2015
    Posts
    4
    Liked
    0 times
    yup i even tried reseating everything else..unfortunately none of em worked


 


Remove Ads

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

toshiba thrive

Click on a term to search our site for related topics.